
Lab 7: Simulations and IV Curves

Prelab

You’ve been using EveryCircuit for simple simulations, but it has significant limitations in regards
to circuit size and realistic component behavior. The industry standard for circuit simulation is
SPICE, and the various incarnations thereof. You’ll be using a free version provided by Linear
Technologies, LTSpice.

• At least one parter needs to install LTSpice on their laptop.
http://www.linear.com/designtools/software/#LTspice

(The interface for the Windows version is distinctly better than the Mac version. You can install
the Windows version on Linux using WINE.)

• Watch the following YouTube video about curve tracers. You will be constructing a nearly
identical setup in lab. https://www.youtube.com/watch?v=Gwo3pEH7hUE

A curve tracer creates a “parametric” plot. This means that the signals plotted on each axis depend
on time, but time itself is not on either axis. At any single moment the graph would just show a
dot. The path the dot traces out as time moves forward is what we call a parametric curve.

Q. In a curve tracer, what is plotted on each axis?

Supplies

• Multimeter (x2)

• Function Generator

• Oscilloscope (and probes)

• Breadboard

• Minigrabber probes w/ adapters

• Computer w/ LTSpice

• 1:1 Audio Transformer (TY-402P)

• 100Ω and 1 kΩ resistors

• 0.33µF capacitors

• 1N4148 and 1N5232 diodes

• Red, White and Blue LEDs

• 100 mH inductor
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Part I: Using LTSpice

1.1 Tutorial

SPICE (Simulation Program with Integrated Circuit Emphasis) is a general-purpose, open source
analog electronic circuit simulator. It is a program used in integrated circuit and board-level design
to check the integrity of circuit designs and to predict circuit behavior.1 It has it’s roots in a class
project and grew into Laurence W. Nagel’s PhD project at Berkeley. It was announced to the world
in 1973 and quickly grew in popularity.

Many derivatives of SPICE have been created which use the same data structures and commands,
one of the most widely used is the version created at Linear Technologies, LTSpice. LTSpice has
both a graphical front end (which you will be using) and a text based interface in which circuit
“netlists” can be defined as a list of components connected to numbered “nodes.”

This is an example of how a circuit can be represented in a textfile. This circuit has one dc voltage
source and three resistors. (A voltage divider with a load.)

v1 1 0 dc 24

r1 1 2 10k

r2 2 0 8.1k

r3 2 0 4.7k

.end

There are text based commands called “SPICE directives” which are used to control the parameters
of the simulation. Much of the functionality is replicated in the graphical interface, but some
isn’t.

Unfortunately the interface is not very user friendly. Figure 1 shows part of the menu with labels
for the various buttons. Below is a list of the more unintuitive aspects which may help you navigate
the software. When you aren’t sure about something, glance back over this list.

Figure 1: LTSpice menu bar

1Wikipedia
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• The general way to interact with a command is to click the icon, then click a location on
the screen or click a component. Hit escape to exit out of a command mode. Clicking and
dragging mostly isn’t a thing. The faster you starting thinking “click, move mouse,
click again, hit escape” as your general work flow, the better.

• Create an empty document using File → New Schematic

• All circuits MUST have a ground point

• “Nets” are the same thing as nodes (constant voltage regions where components connect
together). You can label these to help keep measurements organized.

• “Move” will allow you to move a single component while breaking its connections. Also use
this mode to rotate components.

• “Drag” allows you to move components while keeping the wires attached.

• Right clicking on components brings up edit menus. Note that right clicking on the component
image brings up a different menu than right clicking on the text.

• To set up an analysis, click the running person icon and fill in the relevant values. This
creates a text SPICE directive which you must place anywhere on the page. Right clicking
this allows you to edit the simulation parameters.

• Once you place the directive text box somewhere, clicking “Run” again will run the analysis
and pop up a window showing an empty graph.

• Now, hovering the mouse over wires or components will show a probe icon. Click on wires to
plot voltage (relative to ground) and on components to plot current. Click and hold on one
side of a component and drag to the other side to measure the voltage across a component.

• Left clicking on the trace label (Voltage or Current) gives access to a cursor which can be
dragged along the trace, and a window showing the value at the cursor.

• Right clicking on the trace label lets you edit properties of the trace, and delete the trace.

• To avoid printing out plots with black backgrounds, go to Tools → Color Preferences. Select
“Background” from the drop down menu and change the RGB values all to 255.
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1.2 Practice

Create the circuit shown in figure 2. You must take turns using the software.

Be sure you’ve read through the entire previous section. Mouse over the remaining icons to see the
pop up text describing what they do. Use “Cut” to delete objects or wires.

Be sure to label the input and output nodes/nets to help keep your graph organized.

• Click the Run icon and set the stop time to 1 sec, the time to start saving data to zero
seconds, and the max time step to 0.1 sec.

• Graph the input and output voltage, as well as the current through each resistor. (Enable a
grid through the Plot Settings menu, which will be available after clicking on the plot.)

Q. Compare the value to those you would expect based on your results in Labs 1 and 2. Include
the circuit and graph in your report.

Figure 2: Voltage Divider
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Part II: Simulating Filters

2.1 Transient Analysis

• In LTSpice, construct the filter circuit shown in figure 3.

• To obtain a sinusoidal voltage source, right click the voltage source and go to “Advanced”.
Under Functions, select SINE. Set the amplitude to 10 volts and the frequency to the cutoff
frequency of the filter.

• Set the transient analysis (time domain) to run for 4 milliseconds (enter 4 milliseconds as
“4m”), to start saving data at 1 ms, and to have a max time step of 0.1 ms.

• Plot the input and output voltages.

Q. What do you expect the peak output voltage to be?

Q. Find the peak output on the plot using the cursors and compare.

Now you’ll find the max value using the MEASURE directive.

• Click the SPICE directive icon and enter the following into the text box:

.meas TRAN maxVal MAX V(Output)

This will measure the maximum value of the output voltage during a transient analysis, and assign
the result the name maxVal.

• Run the analysis again.

• For some reason, the result is stored in the error log. Navigate to View → SPICE Error Log
(or use the shortcut CTRL+L).

Q. What value do you get from this method and how does it compare?

Q. Include a screen shot of the graph in your report.

Figure 3: High Pass Filter
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2.2 Bode Plots

To create a plot of attenuation and phase vs frequency, you must change the type of analysis and
the signal source.

• Change the voltage source function to “None” and set the “Small Signal AC Analysis” am-
plitude to 1 volt.

• Edit the simulation directive and change the type to “AC Analysis”

– Set the type of sweep to octave

– Number of points per octave: 20

– Start freq: 10

– Stop freq: 100k

• Run the simulation and confirm that the phase angle is 45 degrees at the cutoff frequency.

Now you’ll use the MEASURE directive to check the cutoff frequency.

• Add a new SPICE directive and enter in the following:

.meas AC Fcut when mag(V(output))=1/sqrt(2)

Q. What frequency does the simulation find to be the cutoff? How does that compare to your
calculation?

Q. Include a screen shot of the circuit and of the Bode plot in your report.

Part III: Diode IV Curves

Current vs voltage plots are a common method of characterizing a component. For a Ohmic
component (like a resistor) the plot is just a straight line where the slope is the inverse of the
resistance (since current is usually plotted on the vertical axis).

For a diode the curve is rather more interesting.

3.1 Circuit Construction

Look at the datasheet (on Moodle) for the 1N4148 diode.

Q. What is the maximum continuous current rating?

• Set the current limit on your DC power supply to that value.

• Set the power supply to zero volts.
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• Using both multimeters, one in voltage mode and one in current mode, construct the circuit
shown in figure 4.

Figure 4: Measure the voltage and current relationship of a diode

• Collect voltage and current data points every 0.05 volts starting at V = 0.3 volts until you
hit the current limit.

• Create three plots of current vs voltage as described below.

– The first plot should have linear axes (I vs V).

– The second plot should look just like the IV curve plot in the diode datasheet.

– The third plot should be like the first, but only include the data points in the linear
region (after the ‘knee’).

Q. If the diode could handle the it, what would be the voltage drop with 1 amp of current? (Use
the linear fit equation for the third plot to predict the voltage.)

3.2 Circuit Simulation

One of the very powerful aspects of LTSpice is its vast library of specific components.

• Create the circuit in figure 5. Once you have placed the diode, right click the symbol and
choose 1N4148.

Figure 5: Simulate the voltage and current relationship of a diode
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Instead of a DC or AC voltage source, you are going to used a “pulsed” voltage source.

• In the voltage source menu, choose PULSE and set it to start at zero volts and rise to 2 volts
over the span of 1 second.

• Set the simulation parameters to also run for 1 second with steps of 0.01 seconds.

Run the simulation and graph the current through the diode. Right click on the time axis and
change it to plot v(out). Resize the plot window to be a square and change the vertical axis to
logarithmic (right click on it). Set the min and max values on the vertical axis to match those in
the data sheet.

Q. What current does the simulation show at 0.8 volts?

Q. What current does the datasheet show? (See footnote)2

Q. What current did you get in your actual circuit?

To make the simulation more accurate, companies provide text files with component models. A
model for the 1N4148 diode from NXP is available for you on Moodle.

• Download the file 1N4148 NXP.model and open it in any text editor.

• While holding down CTRL, right click on the diode symbol and change the value of the value
field (no that wasn’t a typo) to “1N4148NXP” and click Okay.

• Create a new SPICE directive. Copy and paste the context of the text file into the directive’s
text field. Click Okay and then click anywhere on the diagram to place the text.

• Run the simulation again. (You may need readjust the plot axes.)

Q. What current do you now get at 0.8 volts? How does that compare to your previous result?

Part IV: Curve Tracer

In the previous sections you created a plot of current vs voltage by painstakingly measuring many
data points or by using a simulation. Now you’ll build a circuit which can quickly display the IV
curve for any component.

2Warning: The plot in the datasheet is pretty weird. The minor divisions on the vertical axis split each major
division into 5 bins. (The bin spacing gets smaller on the graph because it is logarithmic.) So the division between
1V and 10V (a difference of 9V) is split into 5 equal bins and thus each bin represents 9/5ths or 1.8 volts. Normally
this would be split into a much more sensible 9 bins. The divisions starting at 1 mA will go 1, 2.8, 4,6 6.4, 8.2, 10,
28, 46, 64, 82, 100, . . . . When you make your log plots the software will automatically use the standard bin divisions.
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4.1 Setup

The curve tracer works by measuring the voltage across the device under test (DUT) on channel
1, and the voltage across the 1 kΩ resistor on channel two. For this to be possible, the varying
voltage signal must be floating with respect to the scope ground, which is achieved by decoupling
the function generator through a transformer.

• Use the small yellow transformers called “1:1 audio transformers” to electrically separate the
function generator from the circuit. These will output the same voltage as what is input.

• Use the continuity mode on your multimeter to determine which legs on the transformer are
connected together.

• Put the transformer on the breadboard such that it hangs off the edge, then connect the
function generator to the two legs which should now be hanging in the air.

• Use one of the blue 1% 1 kΩ resistors

• Set up the circuit such that there is a place to easily connect and disconnect various compo-
nents for testing. (Don’t connect probes to the device under test, instead use a short bit of
extra wire.)

• Set both scope probes (and channels!) to 1X mode and DC coupling

• Start with the function generator set at about 150 Hz and the amplitude set to maximum

Figure 6: Curve Tracer Setup

4.2 Normal (YT) mode

• Connect a 1N4148 small signal diode as the device under test (with the low side (marked
with stripe) toward ground).

• Under the channel 2 menu, set Invert to On. This gives the correct sign for the current.

Channel 1 displays the voltage across the component, while channel 2 displays the voltage across
the 1k resistor. The voltage divided by 1kΩ gives current in mA. So voltage readings from channel
2 can be interpreted as mA of current going through the device under test (1 volts = 1 mA).

Q. What max voltage do you measure on channel 1? Explain this value.

Q. What max voltage do you measure on channel 2? What current does that correspond to?
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4.3 Parametric (XY) mode

While viewing the voltage and current as a function of time can be useful, we would like to show
current as a function of voltage. This is done by having the scope plot channel 2 vs channel 1.

• Under “Display” change the format to “XY” increase the “persist” to 1 second.

• Under the menu for channel one, change “coupling” to “Ground.” You should now see a
single vertical line which corresponded to zero voltage location. Shift channel one until this
lines up with the center of the grid lines. Change the coupling back to DC.

• Repeat this procedure for channel two. Now you know the center of the grid corresponds to
zero volts and zero amps.

• Be sure to zoom in and out as needed to see the various plots. Now that you know where the
zero point is you can easily measure values relative to it.

Q. The cursors and measure menu don’t work in XY mode, estimate the max voltage and current
for the diode by eye and compare to the measured values from YT mode.

Q. Include a picture of the IV curve in your report.

4.4 Additional Components

Test the following components. Include pictures of all outputs in your report.

• 5.6V Zener diode (1N5232) – Q. Estimate the forward and reverse breakdown voltages.

• Red, Blue and White LEDs – Q. What are the breakdown voltages for each?

• 100 Ω resistor – Q. Estimate the slope of the line. Calculate resistance from the slope.

• 0.33 µF capacitor – Q. What shape is made? Why?

Q. What effect does changing frequency have? (Specifically pay attention to the vertical am-
plitude, it’s easier to see in the 1kHz range.) Explain the behavior with changing frequency
using the fact that you are applying a voltage of the form v(t) = A sin(ωt) and that the
current through a capacitor is i(t) = Cdv/dt. (Think about v(t) being plotted on the x-axis
and i(t) being plotted on the y-axis.)

• 100 mH inductor – Q. What shape is made?

Q. What effect does changing the frequency have, how does that compare to the capacitor?
(Easier to see in the 10kHz range.) Explain using the equation for the current through an
inductor, i(t) = (1/L)

∫
v(t)dt.
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